Can't install Dexcom watch face after changing phone

I just switched phone to a new Samsung S21 G5 from a Samsung S10. I installed the Dexcom G6 app and it connects correctly to the G6 transmitter.
So far all working as it should.
Now the problem
I can’t install the Dexcom app on my Fossil Gen5 watch. It’s the same watch as I used with the S10 and everything worked great there.

If I remember correctly I should be able to find Dexcom app on the watch by selecting “apps on my phone”, but it isn’t there. Can’t find it when I search the play store on my watch either.

What have missed, why can’t I find the app on my watch h anymore?

I’m sorry I can’t help directly @tellblom but when I first paired my Apple Watch it took a day for me to see compatible apps from my phone. My (poor) advice: Check the Dexcom compatibility page and give it 24 hours

Ok Google is your friend. It seems like the Dexcom App isn’t made for new Wear OS so it isn’t allowed to be installed.

BUT there is a workaround as always made by Malcolm Bryant

I just tried it and it works like a charm. So for all of you who needs to switch phone or reset your android watch here is how you get the Dexcom Watch face back

I had to disable and enable a couple of times before the IPv4 address showed up. It just took IPv6 the first time.

Nightscout is another possible workaround for unsupported platforms. I forgot. Here’s a link